実はhokkai7go

hatenablogに移行しまんた

ローカルマシンで veewee を入れようとしたら net-scp のバージョン依存でさくっと入らなかった件

おはようございます。
そういえば、ローカルマシンに veewee を入れてなかったなと思って、

$ gem i veewee -V --no-ri --no-rdoc

をしたところ、

ERROR:  While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: vagrant requires net-scp (~> 1.0.4)

と怒られました。


最初は素直に、バージョン指定なしに net-scp を入れました

$ gem i net-scp -V --no-ri --no-rdoc 

しかし結局 veewee のインストールで同じエラーががが


ふむふむ v1.0.4 の周辺なら入るのかと、

$ gem i net-scp --version '= 1.0.4' -V --no-ri --no-rdoc

と、v1.0.4 を指定してインストールしました。

$ gem list |grep net-scp                                                                                                                                                                                
net-scp (1.1.0, 1.0.4)


そして再度、veewee のインストール!!

$ gem i veewee -V --no-ri --no-rdoc

あうあうあう、、、 nokogiri のビルドで失敗しておる… native extensionさん…


2013/03/25 10:36追記


vagrant のバージョンを v1.1.0 => v1.1.2 にバージョンアップしたので、
バージョンを確認しようとしたんですが、それだけでもエラーが出てしまった…

$ vagrant -v
Failed to load the "vagrant-aws" plugin. View logs for more details.


vagrant のドキュメントである
http://docs.vagrantup.com/v2/debugging.html
をみてみると、

VAGRANT_LOG=debug vagrant -v

のように、ログレベルを指定した後に、コマンドを続けると詳細なログを確認できるらしい。
どうやって動いているかをうかがい知ることができるかもしれないくらい詳細なログが表示されるんですが、

ERROR root:  -- Error: #<Gem::LoadError: Unable to activate fog-1.9.0, because net-scp-1.1.0 conflicts with net-scp (~> 1.0.4)>

おっとー、これも net-scp のバージョン依存が悪さを…?

http://tk0miya.hatenablog.com/entry/2013/03/15/115710
を見ていると、gem install veewee をするのは茨の道を行く方法だったのだなぁ。。